Author Topic: Help! Drifting screen on monitor! Won't lock into place!  (Read 11131 times)

Offline Phattony4

  • Newbie
  • *
  • Posts: 1
Help! Drifting screen on monitor! Won't lock into place!
« on: February 26, 2008, 01:50:55 pm »
Hey. I have a problem. I recently purchased a Neo Geo cabinet (I
believe it is was converted but I am not sure). The PCB had a graphics
problem, so I replace it. It was originally a 2-slot system, but I
replaced it with a 4-slot which has the jamma connection in a slightly
different spot. My wires did not have a lot of slack, so I had to move
the power supply box and the location of the PCB. Now I can't get the
game screen to lock into place. By adjusting the vertical hold and the
horiz. freq. knobs, I can get it very close but it keeps shifting
slowly along both axis. The monitor used to work flawlessly. But now
every board that I put in gives me the same problem screen not
locking.  The guy I bought it from said he replaced the caps and they
appear to all be in good shape. Everything else about the monitor is
great. It is bright and has good colors.

I think it must be a problem with the wiring because I tugged on it
when moving things around.  I wonder if it could be the composite sync
wire. I am very new to this stuff and not very technical. Can certain
wires not touch other wires, or the power supply, or the metal cover
on the Neo Geo PCB? Maybe something is interferring with the signal.
Should the power supply box be a certain distance from the rest of the
jamma wiring? I am not sure of the chassis model, but I will try to figure that out tonight if that helps.


If anyone could help me out I would greatly appreciate it. And if you
could tell me some simple solutions that may work first because I am
not too technical. Thanks a lot.


Offline DynamiteSJ

  • Newbie
  • *
  • Posts: 11
Re: Help! Drifting screen on monitor! Won't lock into place!
« Reply #1 on: February 10, 2010, 10:44:54 pm »
check your pots and make sure there isnt any play or feel loose